Courier Services During National Lockdown

Minor incident General Notices
2020-03-28 21:14 SAST · 1 week, 4 days, 5 hours, 37 minutes

Updates

Resolved

We continue to deliver essential items during this time.

November 4, 2021 · 17:24 SAST
Monitoring

Please be advised that together with our courier partner we will continue to process and deliver purchases during the lockdown period. Please do expect that there is the possibility of delivery delays.

November 4, 2021 · 17:24 SAST

← Back