MTN Fixed LTE

Major incident Mobile
2020-03-28 11:08 SAST · 1 week, 3 days, 5 hours, 2 minutes

Updates

Resolved

This issue has been resolved.

November 4, 2021 · 17:24 SAST
Investigating

We are receiving reports of newly provisioned clients on MTN Fixed LTE only able to connect on 3G. Our engineers are working with MTN to have this issue resolved. We apologise for any inconvenience caused.

November 4, 2021 · 17:24 SAST

← Back