Telkom Mobile LTE Provisioning

Minor incident Mobile
2020-03-28 10:05 SAST · 1 week, 4 days, 16 hours, 46 minutes

Updates

Resolved

This issue is resolved

November 4, 2021 · 17:24 SAST
Investigating

This issue is resolved.

November 4, 2021 · 17:24 SAST
Investigating

We are experiencing issues communicating with Telkom’s systems in order to process top-ups or to update suspend statuses.

Our engineers are in contact with Telkom to urgently resolve this matter.

We apologise for any inconvenience caused.

November 4, 2021 · 17:24 SAST

← Back